Update auf Karmic Koala (9.10)

By | 13. Dezember 2009

Unser Laptop läuft ja schon eine ganze Weile problemlos mit Kubuntu 9.10. Gestern habe ich also auch unseren „großen“ Rechner auf Karmic Koala geupdatet. Eigentlich keine große Sache aber zwei Dinge haben mir echt den Nerv geraubt. Das Flashplayer-Plugin ließ sich weder updaten noch löschen. Nichts funktionierte, und so habe ich mich entschlossen das Teil aus der

zu löschen. Das ist natürlich nicht zur Nachahmung zu empfehlen. Aber wenn gar nichts mehr geht wohl die einzige Möglichkeit. Der zweite Fehler war da schon einfacher zu beheben. Der Path für die Webcam hatte sich geändert und wurde berichtigt.
Jetzt bleibt nur noch ein Problem, und das nervt mich am meisten. Meine Nvidia Grafikkarte (GeForce 7600 GT) hat keine Lust mehr mit den unfreien Treibern zusammen zu arbeiten. Egal was ich anstelle, der Bildschirm bleibt dunkel. Weder die Installation der nvidia-glx-185 Treiber über apt noch die Installation der 190er Treiber von Nvida brachten mir den gewünschten Erfolg. Zur Zeit läuft zwar die Karte mit den freien „nv“ Treibern aber hier fehlt leider die OpenGL/3D-Unterstützung.

3 thoughts on “Update auf Karmic Koala (9.10)

  1. Martin

    Hm… ich glaube, ich hab grad den selben Grafikfehler besiegt, den Du da auch hast: Mein Rechner wollte nach einem Upgrade auf 9.10 auch keine NVidia-Treiber mehr annehmen. Nach stundenlangem Suchen habe ich herausgefunden, dass man per insmod das Modul nvidia.ko direkt mit Pfadangabe laden kann, also ungefähr so:
    insmod /lib/modules/2.6.31-16-generic/kernel/drivers/video/nvidia.ko

    Danach ging die grafische Oberfläche. Um dies auch noch automatisch beim Start hinzubekommen, hab ich weiterhin im KDM-Startup-Script herumgepfuscht. In /etc/init/kdm.conf habe ich unter der Zeile mit „script“ die folgende eingefügt:
    insmod /lib/modules/uname -r/updates/dkms/nvidia.ko

    Nach dem Abspeichern und Starten des Dienstes KDM bzw. Rechnerneustart sitze ich nun davor und erfreue mich an den Desktop-Effekten ;)
    Die wahre Ursache werde ich bei Gelegenheit mal noch versuchen heraus zu finden, für jetzt muss das reichen.

    Reply
  2. Sysmek Post author

    Hallo Martin,… da bin ich ja beruhigt, dass ich nicht der Einzige bin bei dem das Update so ein Fehler erzeugt hat. Mein Fehler habe ich mittlerweile aber auch schon gefunden http://gettoweb.de/netzwelt/nvidia-lauft-wieder-nach-update/
    Alte modprobe Einträge haben dafür gesorgt das der Treiber nicht geladen werden konnte. Nun genieße auch ich wieder die Desktop-Effekte in vollen Zügen.

    Gruß Dirk

    Reply
  3. Martin

    Hm… ich hab noch extra geschaut, ob ich Deine Lösung irgendwo finde. Tjo, dann werde ich da wohl mal aufräumen, danach sollte es ja auch bei mir wunderbar ohne komische Hacks funktionieren. Vielen Dank für Deinen Hinweis, ich schau mir das an.

    Reply

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.